OpenID
Log In | Register
Skip to main content
Topic: V1.0 - Major Upgrade (Read 1862 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.
V1.0 - Major Upgrade
With over 12 versions of WHM Backup Solutions released since the first script release back in February 2018. The script is now stable and using the latest cPanel API's possible. We've also started to incorporate many features requested by our users and regularly fix any little bugs we identify. So with that its about time we upgrade to our first major version!

So what does this version actually change?
  • MODIFIED: Version Number 1.0
  • ADDED: Privileges Are Now Checked During Generation Of The Backup List.
  • ADDED: An Additional Privilege "basic-whm-functions" Is Now Required In Order To Check The Required Privileges
  • BUG FIX: "Undefined Variable" When Authentication Details Are Incorrect.
  • BUG FIX: If unresolvable WHM Hostname is given in the config file, the script would report HTTP 500 error.
  • BUG FIX: If an error occurred during the backup list generation, no email would be sent.
  • BUG FIX: Resolved Issues With Update Check Function.
  • MODIFIED: Allow sending of system.log in email_log function.
  • MODIFIED: Where possible, allow email to be sent containing system.log.
  • MODIFIED: Authentication Details Incorrect Error Message Revised.

Please note, there may be issues with auto-upgrading from previous versions to this version. The issues have been resolved in this version so all future upgrades shall be problem free.

As per usual, if you have any issues please get in touch!